summaryrefslogtreecommitdiffstats
path: root/plugin/provider_lzma
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/provider_lzma')
-rw-r--r--plugin/provider_lzma/CMakeLists.txt15
-rw-r--r--plugin/provider_lzma/plugin.c55
-rw-r--r--plugin/provider_lzma/provider_lzma.cnf3
3 files changed, 73 insertions, 0 deletions
diff --git a/plugin/provider_lzma/CMakeLists.txt b/plugin/provider_lzma/CMakeLists.txt
new file mode 100644
index 00000000..8b0781aa
--- /dev/null
+++ b/plugin/provider_lzma/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(LibLZMA)
+
+SET(CPACK_RPM_provider-lzma_PACKAGE_SUMMARY "LZMA compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-lzma_PACKAGE_DESCRIPTION "LZMA compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (LIBLZMA_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${LIBLZMA_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_lzma plugin.c COMPONENT provider-lzma
+ LINK_LIBRARIES ${LIBLZMA_LIBRARIES} CONFIG provider_lzma.cnf)
+ENDIF()
diff --git a/plugin/provider_lzma/plugin.c b/plugin/provider_lzma/plugin.c
new file mode 100644
index 00000000..0c18471a
--- /dev/null
+++ b/plugin/provider_lzma/plugin.c
@@ -0,0 +1,55 @@
+/* Copyright (c) 2021, MariaDB Corporation
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA */
+
+#include <stdbool.h>
+#include <mysql_version.h>
+#include <mysql/plugin.h>
+#include <lzma.h>
+#include <providers/lzma.h>
+
+static int init(void* h)
+{
+ provider_service_lzma->lzma_stream_buffer_decode_ptr= lzma_stream_buffer_decode;
+ provider_service_lzma->lzma_easy_buffer_encode_ptr= lzma_easy_buffer_encode;
+
+ provider_service_lzma->is_loaded = true;
+
+ return 0;
+}
+
+static int deinit(void *h)
+{
+ return 1; /* don't unload me */
+}
+
+static struct st_mysql_daemon info= { MYSQL_DAEMON_INTERFACE_VERSION };
+
+maria_declare_plugin(provider_lzma)
+{
+ MYSQL_DAEMON_PLUGIN,
+ &info,
+ "provider_lzma",
+ "Kartik Soneji",
+ "LZMA compression provider",
+ PLUGIN_LICENSE_GPL,
+ init,
+ deinit,
+ 0x0100,
+ NULL,
+ NULL,
+ "1.0",
+ MariaDB_PLUGIN_MATURITY_STABLE
+}
+maria_declare_plugin_end;
diff --git a/plugin/provider_lzma/provider_lzma.cnf b/plugin/provider_lzma/provider_lzma.cnf
new file mode 100644
index 00000000..3a05a356
--- /dev/null
+++ b/plugin/provider_lzma/provider_lzma.cnf
@@ -0,0 +1,3 @@
+[server]
+plugin_load_add=provider_lzma
+provider_lzma=force_plus_permanent