summaryrefslogtreecommitdiffstats
path: root/vio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'vio/CMakeLists.txt')
-rw-r--r--vio/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/vio/CMakeLists.txt b/vio/CMakeLists.txt
new file mode 100644
index 00000000..85810840
--- /dev/null
+++ b/vio/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (c) 2006, 2014, Oracle and/or its affiliates. All rights reserved.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include
+${SSL_INCLUDE_DIRS})
+ADD_DEFINITIONS(${SSL_DEFINES})
+
+SET(VIO_SOURCES vio.c viosocket.c viossl.c viopipe.c viosslfactories.c)
+ADD_CONVENIENCE_LIBRARY(vio ${VIO_SOURCES})
+TARGET_LINK_LIBRARIES(vio ${LIBSOCKET})