summaryrefslogtreecommitdiffstats
path: root/tests/lib/strutil/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:12 +0000
commit8ccb487c21368a7fdc8c7c72315325bf0aa06147 (patch)
treeb2056fae01d325924508a41731edfbd4c3cddd23 /tests/lib/strutil/Makefile.am
parentInitial commit. (diff)
downloadmc-8ccb487c21368a7fdc8c7c72315325bf0aa06147.tar.xz
mc-8ccb487c21368a7fdc8c7c72315325bf0aa06147.zip
Adding upstream version 3:4.8.29.upstream/3%4.8.29upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/lib/strutil/Makefile.am')
-rw-r--r--tests/lib/strutil/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/lib/strutil/Makefile.am b/tests/lib/strutil/Makefile.am
new file mode 100644
index 0000000..6d88f65
--- /dev/null
+++ b/tests/lib/strutil/Makefile.am
@@ -0,0 +1,33 @@
+PACKAGE_STRING = "/lib/strutil"
+
+AM_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ -I$(top_srcdir) \
+ @CHECK_CFLAGS@
+
+LIBS = @CHECK_LIBS@ \
+ $(top_builddir)/lib/libmc.la
+
+if ENABLE_MCLIB
+LIBS += $(GLIB_LIBS)
+endif
+
+TESTS = \
+ replace__str_replace_all \
+ parse_integer \
+ str_verscmp \
+ filevercmp
+
+check_PROGRAMS = $(TESTS)
+
+replace__str_replace_all_SOURCES = \
+ replace__str_replace_all.c
+
+parse_integer_SOURCES = \
+ parse_integer.c
+
+str_verscmp_SOURCES = \
+ str_verscmp.c
+
+filevercmp_SOURCES = \
+ filevercmp.c