summaryrefslogtreecommitdiffstats
path: root/debian/patches/1-disable-openmpi.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:39 +0000
commit289262a517ab91e32d5982dee4c1cdc9c9d7e75a (patch)
tree4fec5a9696c211c3e5cc570327077f5ba290b6d4 /debian/patches/1-disable-openmpi.patch
parentAdding upstream version 1.0.1. (diff)
downloadmeson-289262a517ab91e32d5982dee4c1cdc9c9d7e75a.tar.xz
meson-289262a517ab91e32d5982dee4c1cdc9c9d7e75a.zip
Adding debian version 1.0.1-5.debian/1.0.1-5debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/1-disable-openmpi.patch')
-rw-r--r--debian/patches/1-disable-openmpi.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/patches/1-disable-openmpi.patch b/debian/patches/1-disable-openmpi.patch
new file mode 100644
index 0000000..cda883b
--- /dev/null
+++ b/debian/patches/1-disable-openmpi.patch
@@ -0,0 +1,13 @@
+diff --git a/test cases/frameworks/17 mpi/meson.build b/test cases/frameworks/17 mpi/meson.build
+index 75b463cc..7bf4e7ae 100644
+--- a/test cases/frameworks/17 mpi/meson.build
++++ b/test cases/frameworks/17 mpi/meson.build
+@@ -2,6 +2,8 @@ project('mpi', 'c', 'cpp', default_options: ['b_asneeded=false'])
+
+ method = get_option('method')
+
++error('MESON_SKIP_TEST openmpi binaries do not work when run in pbuilder for some reason.')
++
+ cc = meson.get_compiler('c')
+ mpic = dependency('mpi', language : 'c', required : false, method : method)
+ if not mpic.found()