summaryrefslogtreecommitdiffstats
path: root/test cases/common/165 get project license
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/165 get project license
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/165 get project license')
-rw-r--r--test cases/common/165 get project license/bar.c6
-rw-r--r--test cases/common/165 get project license/meson.build8
2 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/165 get project license/bar.c b/test cases/common/165 get project license/bar.c
new file mode 100644
index 0000000..f1bd822
--- /dev/null
+++ b/test cases/common/165 get project license/bar.c
@@ -0,0 +1,6 @@
+#include<stdio.h>
+
+int main(void) {
+ printf("I'm a main project bar.\n");
+ return 0;
+}
diff --git a/test cases/common/165 get project license/meson.build b/test cases/common/165 get project license/meson.build
new file mode 100644
index 0000000..e7e9deb
--- /dev/null
+++ b/test cases/common/165 get project license/meson.build
@@ -0,0 +1,8 @@
+project('bar', 'c', license: 'Apache-2.0')
+
+executable('bar', 'bar.c')
+
+license = meson.project_license()[0]
+if license != 'Apache-2.0'
+ error('The license should be Apache-2.0, but it is: ' + license)
+endif