summaryrefslogtreecommitdiffstats
path: root/test cases/common/177 subdir_done/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/177 subdir_done/meson.build
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/177 subdir_done/meson.build')
-rw-r--r--test cases/common/177 subdir_done/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test cases/common/177 subdir_done/meson.build b/test cases/common/177 subdir_done/meson.build
new file mode 100644
index 0000000..62346a2
--- /dev/null
+++ b/test cases/common/177 subdir_done/meson.build
@@ -0,0 +1,11 @@
+# Should run, even though main.cpp does not exist and we call error in the last line.
+# subdir_done jumps to end, so both lines are not executed.
+
+project('example exit')
+
+if true
+ subdir_done()
+endif
+
+executable('main', 'main.cpp')
+error('Unreachable')