summaryrefslogtreecommitdiffstats
path: root/test cases/common/19 header in file list/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/19 header in file list/meson.build
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/19 header in file list/meson.build')
-rw-r--r--test cases/common/19 header in file list/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/19 header in file list/meson.build b/test cases/common/19 header in file list/meson.build
new file mode 100644
index 0000000..79eec8d
--- /dev/null
+++ b/test cases/common/19 header in file list/meson.build
@@ -0,0 +1,14 @@
+project('header in file list', 'c')
+
+cc_id = meson.get_compiler('c').get_id()
+cc_ver = meson.get_compiler('c').version()
+
+if cc_id == 'intel' or (cc_id == 'lcc' and cc_ver.version_compare('<=1.23.08'))
+ # ICC and LCC <= 1.23.08 do not escape spaces in paths in the dependency file, so Ninja
+ # (correctly) thinks that the rule has multiple outputs and errors out:
+ # 'depfile has multiple output paths'
+ error('MESON_SKIP_TEST: Skipping test because your compiler is known to generate broken dependency files')
+endif
+
+exe = executable('prog', 'prog.c', 'header.h')
+test('basic', exe)