summaryrefslogtreecommitdiffstats
path: root/test cases/common/199 argument syntax/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/199 argument syntax/meson.build
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/199 argument syntax/meson.build')
-rw-r--r--test cases/common/199 argument syntax/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/test cases/common/199 argument syntax/meson.build b/test cases/common/199 argument syntax/meson.build
new file mode 100644
index 0000000..b97ca74
--- /dev/null
+++ b/test cases/common/199 argument syntax/meson.build
@@ -0,0 +1,19 @@
+project(
+ 'argument syntax',
+ ['c'],
+)
+
+cc = meson.get_compiler('c')
+
+if ['gcc', 'lcc', 'clang', 'intel'].contains(cc.get_id())
+ expected = 'gcc'
+elif ['msvc', 'clang-cl', 'intel-cl'].contains(cc.get_id())
+ expected = 'msvc'
+else
+ # It's possible that other compilers end up here that shouldn't
+ expected = 'other'
+endif
+
+assert(cc.get_argument_syntax() == expected,
+ 'Wrong output for compiler @0@. expected @1@ but got @2@'.format(
+ cc.get_id(), expected, cc.get_argument_syntax()))