summaryrefslogtreecommitdiffstats
path: root/test cases/common/205 native file path override
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/205 native file path override
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/205 native file path override')
-rw-r--r--test cases/common/205 native file path override/main.cpp5
-rw-r--r--test cases/common/205 native file path override/meson.build7
-rw-r--r--test cases/common/205 native file path override/nativefile.ini2
-rw-r--r--test cases/common/205 native file path override/test.json6
4 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/205 native file path override/main.cpp b/test cases/common/205 native file path override/main.cpp
new file mode 100644
index 0000000..91bc809
--- /dev/null
+++ b/test cases/common/205 native file path override/main.cpp
@@ -0,0 +1,5 @@
+#include <iostream>
+
+int main(void) {
+ std::cout << "Hello world!" << std::endl;
+}
diff --git a/test cases/common/205 native file path override/meson.build b/test cases/common/205 native file path override/meson.build
new file mode 100644
index 0000000..142ca1c
--- /dev/null
+++ b/test cases/common/205 native file path override/meson.build
@@ -0,0 +1,7 @@
+project('native file install dir override', 'cpp')
+
+if meson.is_cross_build()
+ error('MESON_SKIP_TEST cannot test native build rules in cross build')
+endif
+
+executable('main', 'main.cpp', install : true)
diff --git a/test cases/common/205 native file path override/nativefile.ini b/test cases/common/205 native file path override/nativefile.ini
new file mode 100644
index 0000000..1c295c7
--- /dev/null
+++ b/test cases/common/205 native file path override/nativefile.ini
@@ -0,0 +1,2 @@
+[paths]
+bindir = 'custom_bindir'
diff --git a/test cases/common/205 native file path override/test.json b/test cases/common/205 native file path override/test.json
new file mode 100644
index 0000000..7954c8e
--- /dev/null
+++ b/test cases/common/205 native file path override/test.json
@@ -0,0 +1,6 @@
+{
+ "installed": [
+ {"type": "exe", "file": "usr/custom_bindir/main"},
+ {"type": "pdb", "file": "usr/custom_bindir/main"}
+ ]
+}