summaryrefslogtreecommitdiffstats
path: root/test cases/common/27 multiline string
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/27 multiline string
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/27 multiline string')
-rw-r--r--test cases/common/27 multiline string/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/test cases/common/27 multiline string/meson.build b/test cases/common/27 multiline string/meson.build
new file mode 100644
index 0000000..a87d29a
--- /dev/null
+++ b/test cases/common/27 multiline string/meson.build
@@ -0,0 +1,37 @@
+project('multiline string', 'c')
+
+x = '''hello again'''
+y = '''hello
+again'''
+
+if x == y
+ error('Things are wrong.')
+endif
+
+multieol = '''
+'''
+singleeol = '\n'
+
+if multieol != singleeol
+ error('Newline quoting is broken.')
+endif
+
+# And one more for good measure.
+quote1 = ''' ' '''.strip()
+quote2 = '\''
+
+if quote1 != quote2
+ error('Single quote quoting is broken.')
+endif
+
+cc = meson.get_compiler('c')
+prog = '''
+#include <stdio.h>
+
+int main(void) {
+ int num = 1;
+ printf("%d\n", num);
+ return 0;
+}'''
+
+assert(cc.compiles(prog), 'multline test compile failed')