summaryrefslogtreecommitdiffstats
path: root/test cases/common/7 mixed
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/7 mixed
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/7 mixed')
-rw-r--r--test cases/common/7 mixed/func.c4
-rw-r--r--test cases/common/7 mixed/main.cc7
-rw-r--r--test cases/common/7 mixed/meson.build3
3 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/7 mixed/func.c b/test cases/common/7 mixed/func.c
new file mode 100644
index 0000000..c76c23d
--- /dev/null
+++ b/test cases/common/7 mixed/func.c
@@ -0,0 +1,4 @@
+int func(void) {
+ int class = 0;
+ return class;
+}
diff --git a/test cases/common/7 mixed/main.cc b/test cases/common/7 mixed/main.cc
new file mode 100644
index 0000000..9a7a7a6
--- /dev/null
+++ b/test cases/common/7 mixed/main.cc
@@ -0,0 +1,7 @@
+extern "C" int func();
+
+class BreakPlainCCompiler;
+
+int main(void) {
+ return func();
+}
diff --git a/test cases/common/7 mixed/meson.build b/test cases/common/7 mixed/meson.build
new file mode 100644
index 0000000..af88a1e
--- /dev/null
+++ b/test cases/common/7 mixed/meson.build
@@ -0,0 +1,3 @@
+project('mixed C and C++', 'c', 'cpp')
+exe = executable('prog', 'main.cc', 'func.c')
+test('mixtest', exe)