summaryrefslogtreecommitdiffstats
path: root/test cases/common/97 find program path
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/97 find program path
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/97 find program path')
-rw-r--r--test cases/common/97 find program path/meson.build22
-rwxr-xr-xtest cases/common/97 find program path/program.py3
2 files changed, 25 insertions, 0 deletions
diff --git a/test cases/common/97 find program path/meson.build b/test cases/common/97 find program path/meson.build
new file mode 100644
index 0000000..23cf956
--- /dev/null
+++ b/test cases/common/97 find program path/meson.build
@@ -0,0 +1,22 @@
+project('find program')
+
+python = import('python3').find_python()
+
+# Source file via string
+prog = find_program('program.py')
+# Source file via files()
+progf = files('program.py')
+# Built file
+py = configure_file(input : 'program.py',
+ output : 'builtprogram.py',
+ configuration : configuration_data())
+
+foreach f : [prog, progf, py, find_program(py), find_program(progf)]
+ ret = run_command(python, f, check: false)
+ assert(ret.returncode() == 0, 'can\'t manually run @0@'.format(prog.path()))
+ assert(ret.stdout().strip() == 'Found', 'wrong output from manually-run @0@'.format(prog.path()))
+
+ ret = run_command(f, check: false)
+ assert(ret.returncode() == 0, 'can\'t run @0@'.format(prog.path()))
+ assert(ret.stdout().strip() == 'Found', 'wrong output from @0@'.format(prog.path()))
+endforeach
diff --git a/test cases/common/97 find program path/program.py b/test cases/common/97 find program path/program.py
new file mode 100755
index 0000000..2ebc564
--- /dev/null
+++ b/test cases/common/97 find program path/program.py
@@ -0,0 +1,3 @@
+#!/usr/bin/env python3
+
+print("Found")