summaryrefslogtreecommitdiffstats
path: root/test cases/failing/115 run_target in test
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/failing/115 run_target in test
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/failing/115 run_target in test')
-rw-r--r--test cases/failing/115 run_target in test/meson.build7
-rw-r--r--test cases/failing/115 run_target in test/test.json8
-rw-r--r--test cases/failing/115 run_target in test/trivial.c6
3 files changed, 21 insertions, 0 deletions
diff --git a/test cases/failing/115 run_target in test/meson.build b/test cases/failing/115 run_target in test/meson.build
new file mode 100644
index 0000000..1d448ec
--- /dev/null
+++ b/test cases/failing/115 run_target in test/meson.build
@@ -0,0 +1,7 @@
+project('trivial test', 'c')
+
+py_inst = import('python').find_installation()
+
+exe = executable('trivialprog', 'trivial.c')
+runt = run_target('invalid', command: [py_inst, '--version'])
+test('runtest', exe, args: runt)
diff --git a/test cases/failing/115 run_target in test/test.json b/test cases/failing/115 run_target in test/test.json
new file mode 100644
index 0000000..6eddb7c
--- /dev/null
+++ b/test cases/failing/115 run_target in test/test.json
@@ -0,0 +1,8 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/115 run_target in test/meson.build:7:0: ERROR: test keyword argument 'args' was of type array[RunTarget] but should have been array[str | File | BuildTarget | CustomTarget | CustomTargetIndex]"
+ }
+ ]
+}
+
diff --git a/test cases/failing/115 run_target in test/trivial.c b/test cases/failing/115 run_target in test/trivial.c
new file mode 100644
index 0000000..96612d4
--- /dev/null
+++ b/test cases/failing/115 run_target in test/trivial.c
@@ -0,0 +1,6 @@
+#include<stdio.h>
+
+int main(void) {
+ printf("Trivial test is working.\n");
+ return 0;
+}