summaryrefslogtreecommitdiffstats
path: root/test cases/python/4 custom target depends extmodule/ext
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/python/4 custom target depends extmodule/ext
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/python/4 custom target depends extmodule/ext')
-rw-r--r--test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c8
-rw-r--r--test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h6
-rw-r--r--test cases/python/4 custom target depends extmodule/ext/lib/meson.build4
-rw-r--r--test cases/python/4 custom target depends extmodule/ext/meson.build6
-rw-r--r--test cases/python/4 custom target depends extmodule/ext/tachyon_module.c51
5 files changed, 75 insertions, 0 deletions
diff --git a/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c b/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c
new file mode 100644
index 0000000..aeff296
--- /dev/null
+++ b/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.c
@@ -0,0 +1,8 @@
+#ifdef _MSC_VER
+__declspec(dllexport)
+#endif
+const char*
+tachyon_phaser_command (void)
+{
+ return "shoot";
+}
diff --git a/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h b/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h
new file mode 100644
index 0000000..dca71d3
--- /dev/null
+++ b/test cases/python/4 custom target depends extmodule/ext/lib/meson-tachyonlib.h
@@ -0,0 +1,6 @@
+#pragma once
+
+#ifdef _MSC_VER
+__declspec(dllimport)
+#endif
+const char* tachyon_phaser_command (void);
diff --git a/test cases/python/4 custom target depends extmodule/ext/lib/meson.build b/test cases/python/4 custom target depends extmodule/ext/lib/meson.build
new file mode 100644
index 0000000..b1f8938
--- /dev/null
+++ b/test cases/python/4 custom target depends extmodule/ext/lib/meson.build
@@ -0,0 +1,4 @@
+libtachyon = shared_library('tachyonlib', 'meson-tachyonlib.c')
+
+libtachyon_dep = declare_dependency(link_with : libtachyon,
+ include_directories : include_directories('.'))
diff --git a/test cases/python/4 custom target depends extmodule/ext/meson.build b/test cases/python/4 custom target depends extmodule/ext/meson.build
new file mode 100644
index 0000000..1bb275d
--- /dev/null
+++ b/test cases/python/4 custom target depends extmodule/ext/meson.build
@@ -0,0 +1,6 @@
+subdir('lib')
+
+pylib = py3.extension_module('tachyon',
+ 'tachyon_module.c',
+ dependencies : [libtachyon_dep, py3_dep],
+)
diff --git a/test cases/python/4 custom target depends extmodule/ext/tachyon_module.c b/test cases/python/4 custom target depends extmodule/ext/tachyon_module.c
new file mode 100644
index 0000000..b48032b
--- /dev/null
+++ b/test cases/python/4 custom target depends extmodule/ext/tachyon_module.c
@@ -0,0 +1,51 @@
+/*
+ Copyright 2016 The Meson development team
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/* A very simple Python extension module. */
+
+#include <Python.h>
+#include <string.h>
+
+#include "meson-tachyonlib.h"
+
+static PyObject* phaserize(PyObject *self, PyObject *args) {
+ const char *message;
+ int result;
+
+ if(!PyArg_ParseTuple(args, "s", &message))
+ return NULL;
+
+ result = strcmp(message, tachyon_phaser_command()) ? 0 : 1;
+ return PyLong_FromLong(result);
+}
+
+static PyMethodDef TachyonMethods[] = {
+ {"phaserize", phaserize, METH_VARARGS,
+ "Shoot tachyon cannons."},
+ {NULL, NULL, 0, NULL}
+};
+
+static struct PyModuleDef tachyonmodule = {
+ PyModuleDef_HEAD_INIT,
+ "tachyon",
+ NULL,
+ -1,
+ TachyonMethods
+};
+
+PyMODINIT_FUNC PyInit_tachyon(void) {
+ return PyModule_Create(&tachyonmodule);
+}