summaryrefslogtreecommitdiffstats
path: root/test cases/rust/17 staticlib link staticlib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/rust/17 staticlib link staticlib
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/rust/17 staticlib link staticlib')
-rw-r--r--test cases/rust/17 staticlib link staticlib/branch.rs4
-rw-r--r--test cases/rust/17 staticlib link staticlib/leaf.rs1
-rw-r--r--test cases/rust/17 staticlib link staticlib/meson.build8
-rw-r--r--test cases/rust/17 staticlib link staticlib/prog.c7
-rw-r--r--test cases/rust/17 staticlib link staticlib/test.json7
5 files changed, 27 insertions, 0 deletions
diff --git a/test cases/rust/17 staticlib link staticlib/branch.rs b/test cases/rust/17 staticlib link staticlib/branch.rs
new file mode 100644
index 0000000..29e1cd0
--- /dev/null
+++ b/test cases/rust/17 staticlib link staticlib/branch.rs
@@ -0,0 +1,4 @@
+#[no_mangle]
+pub extern "C" fn what_have_we_here() -> i32 {
+ leaf::HOW_MANY * leaf::HOW_MANY
+}
diff --git a/test cases/rust/17 staticlib link staticlib/leaf.rs b/test cases/rust/17 staticlib link staticlib/leaf.rs
new file mode 100644
index 0000000..2c697f7
--- /dev/null
+++ b/test cases/rust/17 staticlib link staticlib/leaf.rs
@@ -0,0 +1 @@
+pub const HOW_MANY: i32 = 5;
diff --git a/test cases/rust/17 staticlib link staticlib/meson.build b/test cases/rust/17 staticlib link staticlib/meson.build
new file mode 100644
index 0000000..68d08f3
--- /dev/null
+++ b/test cases/rust/17 staticlib link staticlib/meson.build
@@ -0,0 +1,8 @@
+project('staticlib link staticlib', 'c', 'rust')
+
+leaf = static_library('leaf', 'leaf.rs', rust_crate_type : 'rlib')
+# Even though leaf is linked using link_with, this gets implicitly promoted to link_whole because
+# it is an internal Rust project.
+branch = static_library('branch', 'branch.rs', link_with: leaf, rust_crate_type : 'staticlib', install : true)
+e = executable('prog', 'prog.c', link_with : branch, install : true)
+test('linktest', e)
diff --git a/test cases/rust/17 staticlib link staticlib/prog.c b/test cases/rust/17 staticlib link staticlib/prog.c
new file mode 100644
index 0000000..853391e
--- /dev/null
+++ b/test cases/rust/17 staticlib link staticlib/prog.c
@@ -0,0 +1,7 @@
+#include <stdio.h>
+
+int what_have_we_here();
+
+int main(void) {
+ printf("printing %d\n", what_have_we_here());
+}
diff --git a/test cases/rust/17 staticlib link staticlib/test.json b/test cases/rust/17 staticlib link staticlib/test.json
new file mode 100644
index 0000000..c08ffea
--- /dev/null
+++ b/test cases/rust/17 staticlib link staticlib/test.json
@@ -0,0 +1,7 @@
+{
+ "installed": [
+ {"type": "exe", "file": "usr/bin/prog"},
+ {"type": "pdb", "file": "usr/bin/prog"},
+ {"type": "file", "file": "usr/lib/libbranch.a"}
+ ]
+}