summaryrefslogtreecommitdiffstats
path: root/test cases/windows/14 resources with custom target depend_files/ico
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/windows/14 resources with custom target depend_files/ico
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/windows/14 resources with custom target depend_files/ico')
-rwxr-xr-xtest cases/windows/14 resources with custom target depend_files/ico/gen-ico.py6
-rw-r--r--test cases/windows/14 resources with custom target depend_files/ico/meson.build8
-rw-r--r--test cases/windows/14 resources with custom target depend_files/ico/sample.ico.inbin0 -> 9662 bytes
3 files changed, 14 insertions, 0 deletions
diff --git a/test cases/windows/14 resources with custom target depend_files/ico/gen-ico.py b/test cases/windows/14 resources with custom target depend_files/ico/gen-ico.py
new file mode 100755
index 0000000..c49e0dd
--- /dev/null
+++ b/test cases/windows/14 resources with custom target depend_files/ico/gen-ico.py
@@ -0,0 +1,6 @@
+#!/usr/bin/env python3
+
+import sys
+
+with open(sys.argv[1], 'rb') as infile, open(sys.argv[2], 'wb') as outfile:
+ outfile.write(infile.read())
diff --git a/test cases/windows/14 resources with custom target depend_files/ico/meson.build b/test cases/windows/14 resources with custom target depend_files/ico/meson.build
new file mode 100644
index 0000000..3fae9e8
--- /dev/null
+++ b/test cases/windows/14 resources with custom target depend_files/ico/meson.build
@@ -0,0 +1,8 @@
+ico_writer = find_program('gen-ico.py')
+
+ico = custom_target('makeico',
+ input : 'sample.ico.in',
+ output : 'sample.ico',
+ command : [ico_writer, '@INPUT@', '@OUTPUT@'],
+ install : false,
+ build_always : false)
diff --git a/test cases/windows/14 resources with custom target depend_files/ico/sample.ico.in b/test cases/windows/14 resources with custom target depend_files/ico/sample.ico.in
new file mode 100644
index 0000000..24bd3d9
--- /dev/null
+++ b/test cases/windows/14 resources with custom target depend_files/ico/sample.ico.in
Binary files differ