summaryrefslogtreecommitdiffstats
path: root/test cases/windows/21 masm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/windows/21 masm
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/windows/21 masm')
-rw-r--r--test cases/windows/21 masm/hello.masm33
-rw-r--r--test cases/windows/21 masm/meson.build14
2 files changed, 47 insertions, 0 deletions
diff --git a/test cases/windows/21 masm/hello.masm b/test cases/windows/21 masm/hello.masm
new file mode 100644
index 0000000..a47dc96
--- /dev/null
+++ b/test cases/windows/21 masm/hello.masm
@@ -0,0 +1,33 @@
+; ---------------------------------------------
+; Hello World for Win64 Intel x64 Assembly
+;
+; by fruel (https://github.com/fruel)
+; 13 June 2016
+; ---------------------------------------------
+
+GetStdHandle PROTO
+ExitProcess PROTO
+WriteConsoleA PROTO
+
+.data
+msg BYTE "Hello World!",0
+bytesWritten DWORD ?
+
+.code
+mainCRTStartup proc
+ sub rsp, 5 * 8 ; reserve shadow space
+
+ mov rcx, -11 ; nStdHandle (STD_OUTPUT_HANDLE)
+ call GetStdHandle
+
+ mov rcx, rax ; hConsoleOutput
+ lea rdx, msg ; *lpBuffer
+ mov r8, LENGTHOF msg - 1 ; nNumberOfCharsToWrite
+ lea r9, bytesWritten ; lpNumberOfCharsWritten
+ mov QWORD PTR [rsp + 4 * SIZEOF QWORD], 0 ; lpReserved
+ call WriteConsoleA
+
+ mov rcx, 0 ; uExitCode
+ call ExitProcess
+mainCRTStartup endp
+END
diff --git a/test cases/windows/21 masm/meson.build b/test cases/windows/21 masm/meson.build
new file mode 100644
index 0000000..b6b8fbb
--- /dev/null
+++ b/test cases/windows/21 masm/meson.build
@@ -0,0 +1,14 @@
+project('test-masm', 'c')
+
+if get_option('backend').startswith('vs')
+ error('MESON_SKIP_TEST: masm is not supported by vs backend')
+endif
+
+cc = meson.get_compiler('c')
+
+# MASM must be found when using MSVC, otherwise it is optional
+if not add_languages('masm', required: cc.get_argument_syntax() == 'msvc')
+ error('MESON_SKIP_TEST: masm not available')
+endif
+
+executable('app', 'hello.masm')