summaryrefslogtreecommitdiffstats
path: root/test cases/cmake/21 shared module/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/cmake/21 shared module/meson.build')
-rw-r--r--test cases/cmake/21 shared module/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/test cases/cmake/21 shared module/meson.build b/test cases/cmake/21 shared module/meson.build
new file mode 100644
index 0000000..c6ff957
--- /dev/null
+++ b/test cases/cmake/21 shared module/meson.build
@@ -0,0 +1,13 @@
+project('cmakeSharedModule', ['c', 'cpp'])
+
+cm = import('cmake')
+
+sub_pro = cm.subproject('cmMod')
+sub_dep = sub_pro.dependency('myMod')
+
+dl = meson.get_compiler('c').find_library('dl', required: false)
+
+l = shared_library('runtime', 'runtime.c')
+e = executable('prog', ['prog.c'], link_with: l, dependencies: [sub_dep, dl])
+m = sub_pro.target('myMod')
+test('test1', e, args : m)