summaryrefslogtreecommitdiffstats
path: root/test cases/common/1 trivial/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/1 trivial/meson.build')
-rw-r--r--test cases/common/1 trivial/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/test cases/common/1 trivial/meson.build b/test cases/common/1 trivial/meson.build
new file mode 100644
index 0000000..2e424d5
--- /dev/null
+++ b/test cases/common/1 trivial/meson.build
@@ -0,0 +1,29 @@
+# Comment on the first line
+project('trivial test',
+ # Comment inside a function call + array for language list
+ ['c'], default_options: ['buildtype=debug'],
+ meson_version : '>=0.52.0')
+#this is a comment
+sources = 'trivial.c'
+
+cc = meson.get_compiler('c')
+if cc.get_id() == 'intel'
+ # Error out if the -std=xxx option is incorrect
+ add_project_arguments('-diag-error', '10159', language : 'c')
+elif cc.get_id() == 'intel-cl'
+ add_project_arguments('/Qdiag-error:10159', language : 'c')
+endif
+
+exe = executable('trivialprog', sources : sources)
+assert(exe.name() == 'trivialprog')
+test('runtest', exe) # This is a comment
+
+has_not_changed = false
+if is_disabler(exe)
+ has_not_changed = true
+else
+ has_not_changed = true
+endif
+assert(has_not_changed, 'Executable has changed.')
+
+assert(not is_disabler(exe), 'Executable is a disabler.')