summaryrefslogtreecommitdiffstats
path: root/test cases/common/100 postconf with args
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/100 postconf with args')
-rw-r--r--test cases/common/100 postconf with args/meson.build10
-rw-r--r--test cases/common/100 postconf with args/postconf.py18
-rw-r--r--test cases/common/100 postconf with args/prog.c5
-rw-r--r--test cases/common/100 postconf with args/raw.dat1
4 files changed, 34 insertions, 0 deletions
diff --git a/test cases/common/100 postconf with args/meson.build b/test cases/common/100 postconf with args/meson.build
new file mode 100644
index 0000000..a34502c
--- /dev/null
+++ b/test cases/common/100 postconf with args/meson.build
@@ -0,0 +1,10 @@
+project('postconf script', 'c')
+
+conf = configure_file(
+ configuration : configuration_data(),
+ output : 'out'
+)
+
+meson.add_postconf_script(find_program('postconf.py'), '5', '33', conf)
+
+test('post', executable('prog', 'prog.c'))
diff --git a/test cases/common/100 postconf with args/postconf.py b/test cases/common/100 postconf with args/postconf.py
new file mode 100644
index 0000000..cef7f79
--- /dev/null
+++ b/test cases/common/100 postconf with args/postconf.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+import sys, os
+
+template = '''#pragma once
+
+#define THE_NUMBER {}
+#define THE_ARG1 {}
+#define THE_ARG2 {}
+'''
+
+input_file = os.path.join(os.environ['MESON_SOURCE_ROOT'], 'raw.dat')
+output_file = os.path.join(os.environ['MESON_BUILD_ROOT'], 'generated.h')
+
+with open(input_file) as f:
+ data = f.readline().strip()
+with open(output_file, 'w') as f:
+ f.write(template.format(data, sys.argv[1], sys.argv[2]))
diff --git a/test cases/common/100 postconf with args/prog.c b/test cases/common/100 postconf with args/prog.c
new file mode 100644
index 0000000..5db9d17
--- /dev/null
+++ b/test cases/common/100 postconf with args/prog.c
@@ -0,0 +1,5 @@
+#include"generated.h"
+
+int main(void) {
+ return THE_NUMBER != 9 || THE_ARG1 != 5 || THE_ARG2 != 33;
+}
diff --git a/test cases/common/100 postconf with args/raw.dat b/test cases/common/100 postconf with args/raw.dat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/test cases/common/100 postconf with args/raw.dat
@@ -0,0 +1 @@
+9