summaryrefslogtreecommitdiffstats
path: root/test cases/common/108 ternary/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/108 ternary/meson.build')
-rw-r--r--test cases/common/108 ternary/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test cases/common/108 ternary/meson.build b/test cases/common/108 ternary/meson.build
new file mode 100644
index 0000000..0073a1e
--- /dev/null
+++ b/test cases/common/108 ternary/meson.build
@@ -0,0 +1,12 @@
+project('ternary operator')
+
+x = true
+one = true ? 1 : error('False branch should not be evaluated')
+two = false ? error('True branch should not be evaluated.') : 2
+three = '@0@'.format(x ? 'yes' : 'no')
+four = [x ? '0' : '1']
+
+assert(one == 1, 'Return value from ternary true is wrong.')
+assert(two == 2, 'Return value from ternary false is wrong.')
+assert(three == 'yes', 'Return value for ternary inside method call is wrong.')
+assert(four == ['0'], 'Return value for ternary inside of list is wrong.')