summaryrefslogtreecommitdiffstats
path: root/test cases/common/13 pch/linkwhole/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/13 pch/linkwhole/meson.build')
-rw-r--r--test cases/common/13 pch/linkwhole/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/common/13 pch/linkwhole/meson.build b/test cases/common/13 pch/linkwhole/meson.build
new file mode 100644
index 0000000..dec76ba
--- /dev/null
+++ b/test cases/common/13 pch/linkwhole/meson.build
@@ -0,0 +1,8 @@
+# https://github.com/mesonbuild/meson/issues/10745
+
+l2 = static_library('two', 'lib2.c', c_pch: 'pch2/pch_two.h')
+l1 = static_library('one', 'lib1.c', c_pch: 'pch1/pch_one.h',
+ link_whole: l2)
+
+executable('linkprog', 'main.c',
+ link_with: l1)