summaryrefslogtreecommitdiffstats
path: root/test cases/common/13 pch/mixed/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/13 pch/mixed/meson.build')
-rw-r--r--test cases/common/13 pch/mixed/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/13 pch/mixed/meson.build b/test cases/common/13 pch/mixed/meson.build
new file mode 100644
index 0000000..266e7a5
--- /dev/null
+++ b/test cases/common/13 pch/mixed/meson.build
@@ -0,0 +1,14 @@
+cc = meson.get_compiler('c')
+cc_id = cc.get_id()
+
+# PGI compiler only supports PCH for C++
+if cc_id == 'pgi'
+ subdir_done()
+endif
+
+exe = executable(
+ 'prog',
+ files('main.cc', 'func.c'),
+ c_pch : ['pch/func.h'],
+ cpp_pch : ['pch/main.h'],
+)