summaryrefslogtreecommitdiffstats
path: root/test cases/common/137 whole archive/sh_func2_transdep_func1
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/137 whole archive/sh_func2_transdep_func1')
-rw-r--r--test cases/common/137 whole archive/sh_func2_transdep_func1/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test cases/common/137 whole archive/sh_func2_transdep_func1/meson.build b/test cases/common/137 whole archive/sh_func2_transdep_func1/meson.build
new file mode 100644
index 0000000..0703077
--- /dev/null
+++ b/test cases/common/137 whole archive/sh_func2_transdep_func1/meson.build
@@ -0,0 +1,6 @@
+# Same as sh_func2_dep_func1 but dependency is transitive.
+# func2.c does not have any reference to func1() so without link_whole compiler
+# should throw func1() out.
+sh_func2_transdep_func1 = shared_library(
+ 'sh_func2_transdep_func1', '../func2.c',
+ dependencies : func1_trans_dep)