summaryrefslogtreecommitdiffstats
path: root/test cases/common/144 link depends custom target/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/144 link depends custom target/meson.build')
-rw-r--r--test cases/common/144 link depends custom target/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/144 link depends custom target/meson.build b/test cases/common/144 link depends custom target/meson.build
new file mode 100644
index 0000000..babd58a
--- /dev/null
+++ b/test cases/common/144 link depends custom target/meson.build
@@ -0,0 +1,14 @@
+project('link_depends_custom_target', 'c')
+
+cmd = find_program('make_file.py')
+
+dep_file = custom_target('gen_dep',
+ command: [cmd, '@OUTPUT@'],
+ output: 'dep_file')
+
+exe = executable('foo', 'foo.c',
+ link_depends: dep_file,
+ c_args: ['-DDEPFILE="' + dep_file.full_path()+ '"'])
+
+# check that dep_file exists, which means that link_depends target ran
+test('runtest', exe)