summaryrefslogtreecommitdiffstats
path: root/test cases/common/155 subproject dir name collision/other_subdir
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/155 subproject dir name collision/other_subdir')
-rw-r--r--test cases/common/155 subproject dir name collision/other_subdir/custom_subproject_dir/other.c19
-rw-r--r--test cases/common/155 subproject dir name collision/other_subdir/meson.build1
2 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/155 subproject dir name collision/other_subdir/custom_subproject_dir/other.c b/test cases/common/155 subproject dir name collision/other_subdir/custom_subproject_dir/other.c
new file mode 100644
index 0000000..fa1953e
--- /dev/null
+++ b/test cases/common/155 subproject dir name collision/other_subdir/custom_subproject_dir/other.c
@@ -0,0 +1,19 @@
+#include<stdlib.h>
+
+#if defined _WIN32 || defined __CYGWIN__
+#define DLL_PUBLIC __declspec(dllexport)
+#else
+ #if defined __GNUC__
+ #define DLL_PUBLIC __attribute__ ((visibility("default")))
+ #else
+ #pragma message ("Compiler does not support symbol visibility.")
+ #define DLL_PUBLIC
+ #endif
+#endif
+
+char DLL_PUBLIC func_b(void) {
+ if('c' != 'c') {
+ exit(3);
+ }
+ return 'b';
+}
diff --git a/test cases/common/155 subproject dir name collision/other_subdir/meson.build b/test cases/common/155 subproject dir name collision/other_subdir/meson.build
new file mode 100644
index 0000000..37cb623
--- /dev/null
+++ b/test cases/common/155 subproject dir name collision/other_subdir/meson.build
@@ -0,0 +1 @@
+other = library('other', 'custom_subproject_dir/other.c')