summaryrefslogtreecommitdiffstats
path: root/test cases/common/161 not-found dependency
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/161 not-found dependency')
-rw-r--r--test cases/common/161 not-found dependency/meson.build14
-rw-r--r--test cases/common/161 not-found dependency/sub/meson.build1
-rw-r--r--test cases/common/161 not-found dependency/subprojects/trivial/meson.build3
-rw-r--r--test cases/common/161 not-found dependency/subprojects/trivial/trivial.c3
-rw-r--r--test cases/common/161 not-found dependency/testlib.c0
5 files changed, 21 insertions, 0 deletions
diff --git a/test cases/common/161 not-found dependency/meson.build b/test cases/common/161 not-found dependency/meson.build
new file mode 100644
index 0000000..02072b6
--- /dev/null
+++ b/test cases/common/161 not-found dependency/meson.build
@@ -0,0 +1,14 @@
+project('dep-test', 'c')
+
+dep = dependency('', required:false)
+if dep.found()
+ error('not-found dependency was found')
+endif
+
+assert(dep.type_name() == 'not-found', 'dependency should be of type "not-found" not ' + dep.type_name())
+
+library('testlib', 'testlib.c', dependencies: [dep])
+subdir('sub', if_found: dep)
+
+subdep = dependency('', fallback: ['trivial', 'trivial_dep'])
+missing = dependency('', fallback: ['missing', 'missing_dep'], required: false)
diff --git a/test cases/common/161 not-found dependency/sub/meson.build b/test cases/common/161 not-found dependency/sub/meson.build
new file mode 100644
index 0000000..2a33cae
--- /dev/null
+++ b/test cases/common/161 not-found dependency/sub/meson.build
@@ -0,0 +1 @@
+error('should be disabled by subdir(if_found:)')
diff --git a/test cases/common/161 not-found dependency/subprojects/trivial/meson.build b/test cases/common/161 not-found dependency/subprojects/trivial/meson.build
new file mode 100644
index 0000000..8769c70
--- /dev/null
+++ b/test cases/common/161 not-found dependency/subprojects/trivial/meson.build
@@ -0,0 +1,3 @@
+project('trivial subproject', 'c')
+trivial_lib = static_library('trivial', 'trivial.c', install: false)
+trivial_dep = declare_dependency(link_with: trivial_lib)
diff --git a/test cases/common/161 not-found dependency/subprojects/trivial/trivial.c b/test cases/common/161 not-found dependency/subprojects/trivial/trivial.c
new file mode 100644
index 0000000..cb0c02f
--- /dev/null
+++ b/test cases/common/161 not-found dependency/subprojects/trivial/trivial.c
@@ -0,0 +1,3 @@
+int subfunc(void) {
+ return 42;
+}
diff --git a/test cases/common/161 not-found dependency/testlib.c b/test cases/common/161 not-found dependency/testlib.c
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/common/161 not-found dependency/testlib.c