summaryrefslogtreecommitdiffstats
path: root/test cases/common/17 array
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/17 array')
-rw-r--r--test cases/common/17 array/func.c1
-rw-r--r--test cases/common/17 array/meson.build8
-rw-r--r--test cases/common/17 array/prog.c3
3 files changed, 12 insertions, 0 deletions
diff --git a/test cases/common/17 array/func.c b/test cases/common/17 array/func.c
new file mode 100644
index 0000000..a324dca
--- /dev/null
+++ b/test cases/common/17 array/func.c
@@ -0,0 +1 @@
+int func(void) { return 0; }
diff --git a/test cases/common/17 array/meson.build b/test cases/common/17 array/meson.build
new file mode 100644
index 0000000..0d17374
--- /dev/null
+++ b/test cases/common/17 array/meson.build
@@ -0,0 +1,8 @@
+project('array test', 'c')
+
+arr = [
+ 'func.c',
+ 'prog.c']
+
+exe = executable('prog', sources : arr)
+test('arr test', exe)
diff --git a/test cases/common/17 array/prog.c b/test cases/common/17 array/prog.c
new file mode 100644
index 0000000..f794e1b
--- /dev/null
+++ b/test cases/common/17 array/prog.c
@@ -0,0 +1,3 @@
+extern int func(void);
+
+int main(void) { return func(); }