summaryrefslogtreecommitdiffstats
path: root/test cases/common/177 subdir_done/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/177 subdir_done/meson.build')
-rw-r--r--test cases/common/177 subdir_done/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test cases/common/177 subdir_done/meson.build b/test cases/common/177 subdir_done/meson.build
new file mode 100644
index 0000000..62346a2
--- /dev/null
+++ b/test cases/common/177 subdir_done/meson.build
@@ -0,0 +1,11 @@
+# Should run, even though main.cpp does not exist and we call error in the last line.
+# subdir_done jumps to end, so both lines are not executed.
+
+project('example exit')
+
+if true
+ subdir_done()
+endif
+
+executable('main', 'main.cpp')
+error('Unreachable')