summaryrefslogtreecommitdiffstats
path: root/test cases/common/182 find override/subdir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/182 find override/subdir/meson.build')
-rw-r--r--test cases/common/182 find override/subdir/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/182 find override/subdir/meson.build b/test cases/common/182 find override/subdir/meson.build
new file mode 100644
index 0000000..e5de34d
--- /dev/null
+++ b/test cases/common/182 find override/subdir/meson.build
@@ -0,0 +1,14 @@
+x = find_program('converter.py')
+
+meson.override_find_program('codegen', x)
+
+# Override a command with a generated script
+
+cdata = configuration_data()
+
+cdata.set('NUMBER', 100)
+numprog = configure_file(input : 'gencodegen.py.in',
+ output : 'gencodegen.py',
+ configuration : cdata)
+
+meson.override_find_program('gencodegen', numprog)