summaryrefslogtreecommitdiffstats
path: root/test cases/common/202 custom target build by default
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/202 custom target build by default')
-rw-r--r--test cases/common/202 custom target build by default/docgen.py12
-rw-r--r--test cases/common/202 custom target build by default/meson.build10
-rw-r--r--test cases/common/202 custom target build by default/test.json5
3 files changed, 27 insertions, 0 deletions
diff --git a/test cases/common/202 custom target build by default/docgen.py b/test cases/common/202 custom target build by default/docgen.py
new file mode 100644
index 0000000..f343f21
--- /dev/null
+++ b/test cases/common/202 custom target build by default/docgen.py
@@ -0,0 +1,12 @@
+#!/usr/bin/env python3
+
+import os
+import sys
+
+out = sys.argv[1]
+
+os.mkdir(out)
+
+for name in ('a', 'b', 'c'):
+ with open(os.path.join(out, name + '.txt'), 'w') as f:
+ f.write(name)
diff --git a/test cases/common/202 custom target build by default/meson.build b/test cases/common/202 custom target build by default/meson.build
new file mode 100644
index 0000000..53f0fe6
--- /dev/null
+++ b/test cases/common/202 custom target build by default/meson.build
@@ -0,0 +1,10 @@
+project('custom-target-dir-install')
+
+docgen = find_program('docgen.py')
+
+custom_target('docgen',
+ output : 'html',
+ command : [docgen, '@OUTPUT@'],
+ install : true,
+ build_by_default : false,
+ install_dir : join_paths(get_option('datadir'), 'doc/testpkgname'))
diff --git a/test cases/common/202 custom target build by default/test.json b/test cases/common/202 custom target build by default/test.json
new file mode 100644
index 0000000..df8bcb9
--- /dev/null
+++ b/test cases/common/202 custom target build by default/test.json
@@ -0,0 +1,5 @@
+{
+ "installed": [
+
+ ]
+}