summaryrefslogtreecommitdiffstats
path: root/test cases/common/204 line continuation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/204 line continuation/meson.build')
-rw-r--r--test cases/common/204 line continuation/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/test cases/common/204 line continuation/meson.build b/test cases/common/204 line continuation/meson.build
new file mode 100644
index 0000000..16c72f9
--- /dev/null
+++ b/test cases/common/204 line continuation/meson.build
@@ -0,0 +1,17 @@
+project('line continuation')
+
+a = 1
+b = 2
+
+c = a \
++b
+assert(c == 3, 'Line continuation is not working')
+
+d = a + \
+ b
+assert(d == 3, 'Line continuation is not working')
+
+if a == 1 and \
+ b == 3
+ error('Line continuation in "if" condition is not working')
+endif