summaryrefslogtreecommitdiffstats
path: root/test cases/common/206 tap tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/206 tap tests/meson.build')
-rw-r--r--test cases/common/206 tap tests/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/206 tap tests/meson.build b/test cases/common/206 tap tests/meson.build
new file mode 100644
index 0000000..54f4e41
--- /dev/null
+++ b/test cases/common/206 tap tests/meson.build
@@ -0,0 +1,14 @@
+project('test features', 'c')
+
+tester = executable('tester', 'tester.c')
+cat = executable('cat', 'cat.c')
+test('pass', tester, args : ['ok'], protocol: 'tap')
+test('fail', tester, args : ['not ok'], should_fail: true, protocol: 'tap')
+test('xfail', tester, args : ['not ok # todo'], protocol: 'tap')
+test('xpass', tester, args : ['ok # todo'], should_fail: true, protocol: 'tap')
+test('skip', tester, args : ['ok # skip'], protocol: 'tap')
+test('partially skipped', tester, args : ['ok 1\nok 2 # skip'], suite: ['verbose'], protocol: 'tap', verbose: true)
+test('partially skipped (real-world example)', cat, args : [files('issue7515.txt')], protocol: 'tap')
+test('skip comment', tester, args : ['ok # Skipped: with a comment'], protocol: 'tap')
+test('skip failure', tester, args : ['not ok # skip'], should_fail: true, protocol: 'tap')
+test('no tests', tester, args : ['1..0 # skip'], protocol: 'tap')