summaryrefslogtreecommitdiffstats
path: root/test cases/common/217 test priorities/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/217 test priorities/meson.build')
-rw-r--r--test cases/common/217 test priorities/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/test cases/common/217 test priorities/meson.build b/test cases/common/217 test priorities/meson.build
new file mode 100644
index 0000000..159d56f
--- /dev/null
+++ b/test cases/common/217 test priorities/meson.build
@@ -0,0 +1,22 @@
+project('test priorities')
+
+test_prog = find_program('testprog.py')
+
+test('priority 0', test_prog,
+ args : ['0'],
+)
+
+test('priority neg 10', test_prog,
+ args : ['-10'],
+ priority : -10
+)
+
+test('priority 1000', test_prog,
+ args : ['1000'],
+ priority : 1000
+)
+
+test('priority 50', test_prog,
+ args : ['50'],
+ priority : 50
+)