summaryrefslogtreecommitdiffstats
path: root/test cases/common/67 modules/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/67 modules/meson.build')
-rw-r--r--test cases/common/67 modules/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/67 modules/meson.build b/test cases/common/67 modules/meson.build
new file mode 100644
index 0000000..1cb42c4
--- /dev/null
+++ b/test cases/common/67 modules/meson.build
@@ -0,0 +1,14 @@
+project('module test')
+
+modtest = import('modtest')
+modtest.print_hello()
+assert(modtest.found())
+
+modtest = import('modtest', required : get_option('disabled'))
+assert(not modtest.found())
+
+notfound = import('not-found', required : false)
+assert(not notfound.found())
+
+disabled = import('not-found', required : false, disabler : true)
+assert(is_disabler(disabled))