summaryrefslogtreecommitdiffstats
path: root/test cases/common/77 extract from nested subdir
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/77 extract from nested subdir')
-rw-r--r--test cases/common/77 extract from nested subdir/meson.build8
-rw-r--r--test cases/common/77 extract from nested subdir/src/first/lib_first.c3
-rw-r--r--test cases/common/77 extract from nested subdir/src/first/meson.build1
-rw-r--r--test cases/common/77 extract from nested subdir/src/meson.build1
-rw-r--r--test cases/common/77 extract from nested subdir/tst/first/exe_first.c5
-rw-r--r--test cases/common/77 extract from nested subdir/tst/first/meson.build4
-rw-r--r--test cases/common/77 extract from nested subdir/tst/meson.build1
7 files changed, 23 insertions, 0 deletions
diff --git a/test cases/common/77 extract from nested subdir/meson.build b/test cases/common/77 extract from nested subdir/meson.build
new file mode 100644
index 0000000..000e1aa
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/meson.build
@@ -0,0 +1,8 @@
+project('Extract objects from subdirs', 'c')
+
+if meson.is_unity()
+ message('Unity build: skipping incompatible test')
+else
+ subdir('src')
+ subdir('tst')
+endif
diff --git a/test cases/common/77 extract from nested subdir/src/first/lib_first.c b/test cases/common/77 extract from nested subdir/src/first/lib_first.c
new file mode 100644
index 0000000..5fc3267
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/src/first/lib_first.c
@@ -0,0 +1,3 @@
+int first(void) {
+ return 1001;
+}
diff --git a/test cases/common/77 extract from nested subdir/src/first/meson.build b/test cases/common/77 extract from nested subdir/src/first/meson.build
new file mode 100644
index 0000000..b97aef4
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/src/first/meson.build
@@ -0,0 +1 @@
+first_lib = shared_library('first_lib', 'lib_first.c')
diff --git a/test cases/common/77 extract from nested subdir/src/meson.build b/test cases/common/77 extract from nested subdir/src/meson.build
new file mode 100644
index 0000000..3f5ec32
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/src/meson.build
@@ -0,0 +1 @@
+subdir('first')
diff --git a/test cases/common/77 extract from nested subdir/tst/first/exe_first.c b/test cases/common/77 extract from nested subdir/tst/first/exe_first.c
new file mode 100644
index 0000000..e8188cd
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/tst/first/exe_first.c
@@ -0,0 +1,5 @@
+int first(void);
+
+int main(void) {
+ return first() - 1001;
+}
diff --git a/test cases/common/77 extract from nested subdir/tst/first/meson.build b/test cases/common/77 extract from nested subdir/tst/first/meson.build
new file mode 100644
index 0000000..a6fa7da
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/tst/first/meson.build
@@ -0,0 +1,4 @@
+first_exe = executable('first_exe', 'exe_first.c',
+ objects : first_lib.extract_objects('lib_first.c'))
+
+test('first_test', first_exe)
diff --git a/test cases/common/77 extract from nested subdir/tst/meson.build b/test cases/common/77 extract from nested subdir/tst/meson.build
new file mode 100644
index 0000000..3f5ec32
--- /dev/null
+++ b/test cases/common/77 extract from nested subdir/tst/meson.build
@@ -0,0 +1 @@
+subdir('first')