summaryrefslogtreecommitdiffstats
path: root/test cases/common/8 install/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/8 install/meson.build')
-rw-r--r--test cases/common/8 install/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test cases/common/8 install/meson.build b/test cases/common/8 install/meson.build
new file mode 100644
index 0000000..6eb5ba5
--- /dev/null
+++ b/test cases/common/8 install/meson.build
@@ -0,0 +1,10 @@
+project('install test', 'c', default_options : ['libdir=libtest'])
+
+stlib = static_library('stat', 'stat.c', install : true)
+exe = executable('prog', 'prog.c', install : true)
+
+dirtarget = custom_target('dirtarget',
+ output: ['dir'],
+ install: true,
+ command: [find_program('gendir.py'), '@OUTPUT@'],
+ install_dir: get_option('datadir'))