summaryrefslogtreecommitdiffstats
path: root/test cases/d/2 static library/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/d/2 static library/meson.build')
-rw-r--r--test cases/d/2 static library/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/test cases/d/2 static library/meson.build b/test cases/d/2 static library/meson.build
new file mode 100644
index 0000000..88ed2cb
--- /dev/null
+++ b/test cases/d/2 static library/meson.build
@@ -0,0 +1,5 @@
+project('D Static Library', 'd')
+
+lstatic = static_library('stuff', 'libstuff.d', install : true)
+es = executable('app_s', 'app.d', link_with : lstatic, install : true)
+test('linktest_static', es)