summaryrefslogtreecommitdiffstats
path: root/test cases/failing/13 array arithmetic
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/failing/13 array arithmetic')
-rw-r--r--test cases/failing/13 array arithmetic/meson.build3
-rw-r--r--test cases/failing/13 array arithmetic/test.json7
2 files changed, 10 insertions, 0 deletions
diff --git a/test cases/failing/13 array arithmetic/meson.build b/test cases/failing/13 array arithmetic/meson.build
new file mode 100644
index 0000000..f43f81c
--- /dev/null
+++ b/test cases/failing/13 array arithmetic/meson.build
@@ -0,0 +1,3 @@
+project('array arithmetic')
+
+foo = ['a', 'b'] * 3
diff --git a/test cases/failing/13 array arithmetic/test.json b/test cases/failing/13 array arithmetic/test.json
new file mode 100644
index 0000000..8904775
--- /dev/null
+++ b/test cases/failing/13 array arithmetic/test.json
@@ -0,0 +1,7 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/13 array arithmetic/meson.build:3:0: ERROR: Object <[ArrayHolder] holds [list]: ['a', 'b']> of type array does not support the `*` operator."
+ }
+ ]
+}