summaryrefslogtreecommitdiffstats
path: root/test cases/failing/29 nested ternary
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/failing/29 nested ternary')
-rw-r--r--test cases/failing/29 nested ternary/meson.build3
-rw-r--r--test cases/failing/29 nested ternary/test.json7
2 files changed, 10 insertions, 0 deletions
diff --git a/test cases/failing/29 nested ternary/meson.build b/test cases/failing/29 nested ternary/meson.build
new file mode 100644
index 0000000..76364ce
--- /dev/null
+++ b/test cases/failing/29 nested ternary/meson.build
@@ -0,0 +1,3 @@
+project('nested ternary')
+
+x = true ? (false ? 1 : 0) : 2
diff --git a/test cases/failing/29 nested ternary/test.json b/test cases/failing/29 nested ternary/test.json
new file mode 100644
index 0000000..ba05013
--- /dev/null
+++ b/test cases/failing/29 nested ternary/test.json
@@ -0,0 +1,7 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/29 nested ternary/meson.build:3:12: ERROR: Nested ternary operators are not allowed."
+ }
+ ]
+}