summaryrefslogtreecommitdiffstats
path: root/test cases/failing/41 custom target outputs not matching install_dirs/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/failing/41 custom target outputs not matching install_dirs/meson.build')
-rw-r--r--test cases/failing/41 custom target outputs not matching install_dirs/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/test cases/failing/41 custom target outputs not matching install_dirs/meson.build b/test cases/failing/41 custom target outputs not matching install_dirs/meson.build
new file mode 100644
index 0000000..ed99dba
--- /dev/null
+++ b/test cases/failing/41 custom target outputs not matching install_dirs/meson.build
@@ -0,0 +1,13 @@
+project('outputs not matching install_dirs')
+
+gen = find_program('generator.py')
+
+if meson.backend() != 'ninja'
+ error('MESON_SKIP_TEST test is only for the ninja backend')
+endif
+
+custom_target('too-few-install-dirs',
+ output : ['toofew.h', 'toofew.c', 'toofew.sh'],
+ command : [gen, 'toofew', '@OUTDIR@'],
+ install : true,
+ install_dir : [join_paths(get_option('prefix'), get_option('includedir')), false])