summaryrefslogtreecommitdiffstats
path: root/test cases/failing/55 or on new line
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/failing/55 or on new line')
-rw-r--r--test cases/failing/55 or on new line/meson.build7
-rw-r--r--test cases/failing/55 or on new line/meson_options.txt1
-rw-r--r--test cases/failing/55 or on new line/test.json7
3 files changed, 15 insertions, 0 deletions
diff --git a/test cases/failing/55 or on new line/meson.build b/test cases/failing/55 or on new line/meson.build
new file mode 100644
index 0000000..b0bd08e
--- /dev/null
+++ b/test cases/failing/55 or on new line/meson.build
@@ -0,0 +1,7 @@
+project('silent_or')
+
+if get_option('foo') == 'true'
+ or get_option('foo') == 'auto'
+else
+ message('If this message is printed then something is wrong. The or above should give a syntax error.')
+endif
diff --git a/test cases/failing/55 or on new line/meson_options.txt b/test cases/failing/55 or on new line/meson_options.txt
new file mode 100644
index 0000000..3302cf4
--- /dev/null
+++ b/test cases/failing/55 or on new line/meson_options.txt
@@ -0,0 +1 @@
+option('foo', type: 'combo', choices: ['true', 'false', 'auto'], value: 'auto')
diff --git a/test cases/failing/55 or on new line/test.json b/test cases/failing/55 or on new line/test.json
new file mode 100644
index 0000000..f1b8a67
--- /dev/null
+++ b/test cases/failing/55 or on new line/test.json
@@ -0,0 +1,7 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/55 or on new line/meson.build:4:8: ERROR: Invalid or clause."
+ }
+ ]
+}