summaryrefslogtreecommitdiffstats
path: root/test cases/frameworks/23 hotdoc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/frameworks/23 hotdoc/meson.build')
-rw-r--r--test cases/frameworks/23 hotdoc/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/frameworks/23 hotdoc/meson.build b/test cases/frameworks/23 hotdoc/meson.build
new file mode 100644
index 0000000..64cd6da
--- /dev/null
+++ b/test cases/frameworks/23 hotdoc/meson.build
@@ -0,0 +1,14 @@
+project('hotdoc', 'c')
+
+hotdoc = find_program('hotdoc', required: false)
+if not hotdoc.found()
+ error('MESON_SKIP_TEST hotdoc not found.')
+endif
+
+subdir('doc')
+
+assert(hotdoc.has_extensions(['gi-extension']) == true,
+ 'GI extension should always be found.')
+
+assert(hotdoc.has_extensions(['gi-extension', 'no-way-you-exist-extension']) == false,
+ 'A hotdoc extension called "no-way-you-exist-extension" should never be found.')