summaryrefslogtreecommitdiffstats
path: root/test cases/keyval/2 subdir/dir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/keyval/2 subdir/dir/meson.build')
-rw-r--r--test cases/keyval/2 subdir/dir/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test cases/keyval/2 subdir/dir/meson.build b/test cases/keyval/2 subdir/dir/meson.build
new file mode 100644
index 0000000..3db80ad
--- /dev/null
+++ b/test cases/keyval/2 subdir/dir/meson.build
@@ -0,0 +1,12 @@
+
+k = import('keyval')
+
+conf = k.load(meson.source_root() / '.config')
+
+if not conf.has_key('CONFIG_IS_SET')
+ error('Expected CONFIG_IS_SET to be set, but it wasn\'t')
+endif
+
+if conf.has_key('CONFIG_NOT_IS_SET')
+ error('Expected CONFIG_NOT_IS_SET not be set, but it was')
+endif