summaryrefslogtreecommitdiffstats
path: root/test cases/python/3 cython/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python/3 cython/meson.build')
-rw-r--r--test cases/python/3 cython/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/test cases/python/3 cython/meson.build b/test cases/python/3 cython/meson.build
new file mode 100644
index 0000000..5fc07a8
--- /dev/null
+++ b/test cases/python/3 cython/meson.build
@@ -0,0 +1,26 @@
+project('cython', 'c',
+ default_options : ['warning_level=3'])
+
+if meson.backend() != 'ninja'
+ error('MESON_SKIP_TEST: Ninja backend required')
+endif
+
+cython = find_program('cython', required : false)
+if not cython.found()
+ error('MESON_SKIP_TEST: Cython3 not found.')
+endif
+
+py_mod = import('python')
+py3 = py_mod.find_installation()
+py3_dep = py3.dependency(required: false)
+if not py3_dep.found()
+ error('MESON_SKIP_TEST: Python library not found.')
+endif
+
+subdir('libdir')
+
+test('cython tester',
+ py3,
+ args : files('cytest.py'),
+ env : ['PYTHONPATH=' + pydir]
+)