summaryrefslogtreecommitdiffstats
path: root/test cases/python/5 modules kwarg/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python/5 modules kwarg/meson.build')
-rw-r--r--test cases/python/5 modules kwarg/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test cases/python/5 modules kwarg/meson.build b/test cases/python/5 modules kwarg/meson.build
new file mode 100644
index 0000000..9751ada
--- /dev/null
+++ b/test cases/python/5 modules kwarg/meson.build
@@ -0,0 +1,7 @@
+project('python kwarg')
+
+py = import('python')
+prog_python = py.find_installation('python3', modules : ['distutils'])
+assert(prog_python.found() == true, 'python not found when should be')
+prog_python = py.find_installation('python3', modules : ['thisbetternotexistmod'], required : false)
+assert(prog_python.found() == false, 'python not found but reported as found')