summaryrefslogtreecommitdiffstats
path: root/test cases/python/7 install path/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python/7 install path/meson.build')
-rw-r--r--test cases/python/7 install path/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test cases/python/7 install path/meson.build b/test cases/python/7 install path/meson.build
new file mode 100644
index 0000000..1075c1b
--- /dev/null
+++ b/test cases/python/7 install path/meson.build
@@ -0,0 +1,20 @@
+project('install path',
+ default_options: [
+ 'python.purelibdir=/pure',
+ 'python.platlibdir=/plat'
+ ]
+)
+
+py = import('python').find_installation()
+py.install_sources('test.py')
+py.install_sources('test.py', pure: false)
+install_data('test.py', install_dir: py.get_install_dir() / 'data')
+install_data('test.py', install_dir: py.get_install_dir(pure: false) / 'data')
+
+py_plat = import('python').find_installation(pure: false)
+py_plat.install_sources('test.py', subdir: 'kw')
+py_plat.install_sources('test.py', pure: true, subdir: 'kwrevert')
+install_data('test.py', install_dir: py_plat.get_install_dir() / 'kw/data')
+install_data('test.py', install_dir: py_plat.get_install_dir(pure: true) / 'kwrevert/data')
+
+subdir('structured')