summaryrefslogtreecommitdiffstats
path: root/test cases/python/7 install path
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/python/7 install path')
-rw-r--r--test cases/python/7 install path/meson.build20
-rw-r--r--test cases/python/7 install path/structured/alpha/one.py0
-rw-r--r--test cases/python/7 install path/structured/alpha/three.py0
-rw-r--r--test cases/python/7 install path/structured/alpha/two.py0
-rw-r--r--test cases/python/7 install path/structured/beta/one.py0
-rw-r--r--test cases/python/7 install path/structured/meson.build9
-rw-r--r--test cases/python/7 install path/structured/one.py0
-rw-r--r--test cases/python/7 install path/structured/two.py0
-rw-r--r--test cases/python/7 install path/test.json18
-rw-r--r--test cases/python/7 install path/test.py0
10 files changed, 47 insertions, 0 deletions
diff --git a/test cases/python/7 install path/meson.build b/test cases/python/7 install path/meson.build
new file mode 100644
index 0000000..1075c1b
--- /dev/null
+++ b/test cases/python/7 install path/meson.build
@@ -0,0 +1,20 @@
+project('install path',
+ default_options: [
+ 'python.purelibdir=/pure',
+ 'python.platlibdir=/plat'
+ ]
+)
+
+py = import('python').find_installation()
+py.install_sources('test.py')
+py.install_sources('test.py', pure: false)
+install_data('test.py', install_dir: py.get_install_dir() / 'data')
+install_data('test.py', install_dir: py.get_install_dir(pure: false) / 'data')
+
+py_plat = import('python').find_installation(pure: false)
+py_plat.install_sources('test.py', subdir: 'kw')
+py_plat.install_sources('test.py', pure: true, subdir: 'kwrevert')
+install_data('test.py', install_dir: py_plat.get_install_dir() / 'kw/data')
+install_data('test.py', install_dir: py_plat.get_install_dir(pure: true) / 'kwrevert/data')
+
+subdir('structured')
diff --git a/test cases/python/7 install path/structured/alpha/one.py b/test cases/python/7 install path/structured/alpha/one.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/alpha/one.py
diff --git a/test cases/python/7 install path/structured/alpha/three.py b/test cases/python/7 install path/structured/alpha/three.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/alpha/three.py
diff --git a/test cases/python/7 install path/structured/alpha/two.py b/test cases/python/7 install path/structured/alpha/two.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/alpha/two.py
diff --git a/test cases/python/7 install path/structured/beta/one.py b/test cases/python/7 install path/structured/beta/one.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/beta/one.py
diff --git a/test cases/python/7 install path/structured/meson.build b/test cases/python/7 install path/structured/meson.build
new file mode 100644
index 0000000..6c85587
--- /dev/null
+++ b/test cases/python/7 install path/structured/meson.build
@@ -0,0 +1,9 @@
+py.install_sources(
+ 'one.py',
+ 'two.py',
+ 'alpha/one.py',
+ 'alpha/two.py',
+ 'alpha/three.py',
+ 'beta/one.py',
+ preserve_path: true,
+)
diff --git a/test cases/python/7 install path/structured/one.py b/test cases/python/7 install path/structured/one.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/one.py
diff --git a/test cases/python/7 install path/structured/two.py b/test cases/python/7 install path/structured/two.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/structured/two.py
diff --git a/test cases/python/7 install path/test.json b/test cases/python/7 install path/test.json
new file mode 100644
index 0000000..cf8e7a9
--- /dev/null
+++ b/test cases/python/7 install path/test.json
@@ -0,0 +1,18 @@
+{
+ "installed": [
+ {"type": "file", "file": "pure/one.py"},
+ {"type": "file", "file": "pure/two.py"},
+ {"type": "file", "file": "pure/alpha/one.py"},
+ {"type": "file", "file": "pure/alpha/two.py"},
+ {"type": "file", "file": "pure/alpha/three.py"},
+ {"type": "file", "file": "pure/beta/one.py"},
+ {"type": "file", "file": "plat/kw/test.py"},
+ {"type": "file", "file": "pure/kwrevert/test.py"},
+ {"type": "file", "file": "plat/test.py"},
+ {"type": "file", "file": "pure/test.py"},
+ {"type": "file", "file": "plat/data/test.py"},
+ {"type": "file", "file": "pure/data/test.py"},
+ {"type": "file", "file": "plat/kw/data/test.py"},
+ {"type": "file", "file": "pure/kwrevert/data/test.py"}
+ ]
+}
diff --git a/test cases/python/7 install path/test.py b/test cases/python/7 install path/test.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/python/7 install path/test.py