summaryrefslogtreecommitdiffstats
path: root/test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build')
-rw-r--r--test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build b/test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build
new file mode 100644
index 0000000..2a6e30a
--- /dev/null
+++ b/test cases/unit/107 new subproject on reconfigure/subprojects/foo/meson.build
@@ -0,0 +1,8 @@
+project('foo', 'c')
+
+# Ensure that builtin options have been initialised.
+assert(get_option('default_library') == 'shared')
+
+# This uses default_library option internally and used to cause a crash:
+# https://github.com/mesonbuild/meson/issues/10225.
+library('foo', 'foo.c')