summaryrefslogtreecommitdiffstats
path: root/test cases/unit/14 testsetup selection/subprojects/foo
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/14 testsetup selection/subprojects/foo')
-rw-r--r--test cases/unit/14 testsetup selection/subprojects/foo/foo.c3
-rw-r--r--test cases/unit/14 testsetup selection/subprojects/foo/meson.build4
2 files changed, 7 insertions, 0 deletions
diff --git a/test cases/unit/14 testsetup selection/subprojects/foo/foo.c b/test cases/unit/14 testsetup selection/subprojects/foo/foo.c
new file mode 100644
index 0000000..9b6bdc2
--- /dev/null
+++ b/test cases/unit/14 testsetup selection/subprojects/foo/foo.c
@@ -0,0 +1,3 @@
+int main(void) {
+ return 0;
+}
diff --git a/test cases/unit/14 testsetup selection/subprojects/foo/meson.build b/test cases/unit/14 testsetup selection/subprojects/foo/meson.build
new file mode 100644
index 0000000..2eef840
--- /dev/null
+++ b/test cases/unit/14 testsetup selection/subprojects/foo/meson.build
@@ -0,0 +1,4 @@
+project('foo', 'c')
+foo = executable('foo', 'foo.c')
+test('Test foo', foo)
+add_test_setup('worksforall')